Cmake error at cmake_install.cmake:36

While installing the binaries according to ‘’ I have encountered an error stating that cannot copy file libosqp.a.


Thanks and Regards,

Could you please post the whole compilation log? I suspect the library is not generated because of an error happening earlier.


Please find the log file

Which shell are you running these commands from? What happens if you run them from the native Windows Command Prompt?

I was running the commands from git bash.
I am getting the below error when executed from windows command prompt


There is apparently a problem with git or the PATH variable is not set properly.

What happens if you clone the repository from git bash and then run the compilation commands from the Command Prompt?

Earlier problem was due to absence of sh.exe in git\bin. LAter I restored and the error mentioned “maybe git-submodule is broken?” is rectified.

Now, when I run the commands in windows command prompt, I am getting the same cmake error as mentioned earlier.
Here I am attaching the log file when I run the commands in command prompt

You probably need administrative privileges to run

cmake --build . --target install

Open the Command Prompt as administrator and then run the command above.

It worked. Thanks.

In code generation process, should I have to involve the build directory which has been created now? or it is totally independant ?

I am aiming for code generation and later implement on embedded platform (TI Delfino).

I have already generated code without performing ‘Build from sources’ mentioned in webpage. The generated code(C Project) has created error when built in ‘Codeblocks IDE’ environment. Then I removed the cmake files and executed/compiled in ‘codeblocks IDE’ which worked fine.


Is there any sources available for embedded implementaion of OSQP? (apart from publication ‘Embedded code gneration using OSQP solver’)